[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Update Error on f10



On Sun, 26 Jul 2009 18:43:24 -0400, vincent wrote:

> Hi,
> The following is the error file from an auto update.
> Can any of you good people tell me what is wrong and how to fix?
> It is while that I could not do update, help would be most appreciate.
> Thank you. Vinny
>      
> Error Type: <type 'exceptions.IndexError'>
> Error Value: list index out of range
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2329, in
> <module>
>     main()
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2326, in
> main
>     backend.dispatcher(sys.argv[1:])
>   File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line
> 606, in dispatcher
>     self.dispatch_command(args[0], args[1:])
>   File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line
> 584, in dispatch_command
>     self.update_system()
>   File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1102, in
> update_system
>     txmbr = self.yumbase.update() # Add all updates to Transaction
>   File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 2829, in
> update
>     tx_return.extend(self.update(po=self.getPackageObject(new)))
>   File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 2965, in
> update
>     updated_pkg =  self.rpmdb.searchPkgTuple(updated)[0]

Please try the following:

1) Open your favourite terminal and log in as root user by
running:  su -

2) Run   yum clean metadata dbcache

3) Run   yum -y update yum PackageKit-yum ; yum update



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]