[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F11: kill -9 doesn't work



Terry Barnaby wrote:
On 07/24/2009 10:40 PM, Bill Davidsen wrote:


Currently if I run paraview, X goes to 100% and I can no longer
operate the system via mouse/keyboard. Via a network login I
can "killall -9 X" but that does nothing to X. I have also
tried killing paraview in the same way with no effect (possibly
after trying to kill X).

I hope this is a typo, process "X" is long gone, the X process is called
"Xorg" now. I assume you had a finger check and actually killed the real
X process.

On F11 "Xorg" is hard linked to "X" and "X" is the program started.
So in "ps" listings the XServer process is named "X" and to kill it
with "killall" you need to do a "killall -9 X" ...

On my system both top and ps show it as Xorg, FC9 and FC10. I don't have an FC11 machine handy right now, so I can't swear to that, but 'killall Xorg' sure kills X in a VM!

Anyway, since your problem is solved it's not an issue.

--
Bill Davidsen <davidsen tmr com>
  "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]