Mute button on T61 doesn't work in F11

Mike Wright mike.wright at
Tue Jul 28 17:37:18 UTC 2009

Hi Matthew,

I've lost the original message-id so I've started a new thread with the 
same subject (nabble, gmane, etc. don't provide the original message 

I'm guessing that your mute control and volume controls have become 
attached to different sound channels.

I had a similar problem on f10.  I listen to a radio tuner that's fed 
into "Line In".

At first the kb mute, volume up, and volume down buttons worked.  Then 
the mute button went on vacation, i.e. when pressed the popup would show 
muted but the sound was not muted.  Then yesterday morning I popped in a 
  CD which brought up Rhythmbox.  Volume AND mute buttons were both 
working.  Well, me thinks, this is cool.

After the CD finished I went back to my radio on Line In but then none 
of the keyboard controls worked. :(

It turns out that there is the system volume control (by default on the 
default toolbar), the volume controls on the alsamixer, and another 
controller found at System->Preferences->Hardware->Sound.  From there go 
  to Default Mixer Tracks and choose (Alsa mixer) from the dropdown box. 
  There you will see the same controls as on the alsamixer.  By holding 
shift-control one can select multiple channels to control from the 
keyboard.  (I deselected master and selected both PCM and Line-in).

Voila'.  Now the main volume control handles the master channel and the 
keyboard controls pcm and line-in.  Since I only use one at a time there 
is no conflict for me.

What had happened?  Can't say for sure but it seems the the mute button 
had become attached to pcm while volume controls were attached to 
line-in (which later moved mysteriously to pcm).

So... there is definitely a bug in there somewhere but I don't know 
enough yet to help track it down.

Hope that helps.

More information about the fedora-list mailing list