[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Sound is gone



On 07/29/2009 11:01 AM, Anne Wilson wrote:
On Wednesday 29 July 2009 18:53:15 Anne Wilson wrote:
  
On Wednesday 29 July 2009 18:32:52 jack craig wrote:
    
On 07/29/2009 10:17 AM, Antonio M wrote:
      
after latest updates, any sound application when palys streams from
the net crashes after a short time.
No idea what is causing such a problem
        
explore recent threads, look at your /var/log/messages and see if our
recent discovery is also your problem?

i have a work around if you are getting alsa bug reports in your
messages file.

hth, jackc...
      
How about a clue, Jack?  So much hokum has been talked that I've been
skipping the sound threads, particularly as everything else plays
correctly.  I thought or a moment that I was going to get a whole track
played (my problem is in amarok, but exactly the same as the rhythmbox
one).  This is what happened:

Jul 29 18:45:33 anne-laptop pulseaudio[26616]: ratelimit.c: 7106 events
suppressed
Jul 29 18:45:33 anne-laptop pulseaudio[26616]: alsa-sink.c: Increasing
minimal latency to 56.00 ms
Jul 29 18:48:26 anne-laptop pulseaudio[26616]: alsa-sink.c: Increasing
wakeup watermark to 46.00 ms
Jul 29 18:48:31 anne-laptop pulseaudio[26616]: ratelimit.c: 6194 events
suppressed
Jul 29 18:48:36 anne-laptop pulseaudio[26616]: ratelimit.c: 6014 events
suppressed
Jul 29 18:48:38 anne-laptop kernel: kio_thumbnail[808]: segfault at 1320 ip
00a4f1de sp bfa0848c error 4 in libgcc_s-4.4.0-20090506.so.1[a2e000+2a000]
^C

The moment of the 'Increasing wakeup watermark' message is when it started
to race and crackle.

Is this what you were expecting to see?  I so, what's the workaround?

Just out of curiosity, I'll do the same experiment while playing it in
kaffeine, as I have never seen it happen there.  It will be interesting to
see whether the same messages appear.

    
Yes, in kaffeine the same thing happened.  Everything was going swimmingly 
until

Jul 29 18:58:51 anne-laptop pulseaudio[26616]: ratelimit.c: 4191 events 
suppressed
Jul 29 18:58:51 anne-laptop pulseaudio[26616]: alsa-sink.c: Increasing wakeup 
watermark to 56.00 ms
Jul 29 18:58:56 anne-laptop pulseaudio[26616]: ratelimit.c: 6390 events 
suppressed
Jul 29 18:59:01 anne-laptop pulseaudio[26616]: ratelimit.c: 5688 events 
suppressed

So it's an alsa bug?

Anne
  
sorry, i didnt want to pollute the group with WAG's if its not the same issue.

see
https://bugzilla.redhat.com/show_bug.cgi?id=514213

for defect details.

this is apparently fixed in the mainline and due next release.
i am curious if you dont also get the messages entry about the alsa bug for snd_pcm_delay() ?

anyway, the fix that worked for me, posted earlier, ...

to disable the g-f feature. do this, in 

/etc/pulse/default.pa,

change, ...

load-module module-hal-detect

to

load-module module-hal-detect tsched=0

kill off the existing pulseaudio daemon so it restarts and reads the config update.

hth, jackc...


-- 
   jack craig
      jackc LinuxLightHouse com
         831-684-1375 (Office)
            831-596-6924 (cell)
               IM: jackcraigaptos (AIM)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]