[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problems after a yum upgrade from F10 to F11



stan <gryt2 q com> writes:

> On Wed, 29 Jul 2009 14:56:19 +0200
> lars bjorndal broadpark no (Lars Bjørndal) wrote:
>
>> Hope someone can help me with the following two issues. I've used
>> yum to upgrade from Fedora 10 to Fedora 11.
>> 
>> The computer is an Lenove X61S laptop. Output from 'uname -rv' is:
>> '2.6.29.6-213.fc11.i686.PAE #1 SMP Tue Jul 7 20:59:29 EDT 2009'.
>> 
>> 1. Text mode
>> 
>> I prefere to use the console, e.g. text only mode, and so I've set the
>> system to start up in runlevel 3. Output from 'runlevel' is 'N 3'.
>> 
>> The problem is that I get 48 lines and many more columns than the
>> usual 80 (don't remember exactly how many).
>> 
>> In /etc/grub.conf, I have added the vga=normal paramtere, as follows:
>> 
>> title Fedora (2.6.29.6-213.fc11.i686.PAE)
>>         root (hd0,2)
>>         kernel /vmlinuz-2.6.29.6-213.fc11.i686.PAE ro
>>         root=/dev/vg/root0
>>         initrd /initrd-2.6.29.6-213.fc11.i686.PAE.img vga=normal
>> 
>> In the /var/log/messages, I see a line like this:
>> 
>> Jul 29 12:45:03 lapx kernel: Console: colour VGA+ 80x25
>> 
>> Even thoug, after logging in on the console, I have too many lines and
>> columns. Also, I can see that the environment variables LINES and
>> COLUMNS are set to the amount of lines/columns that are displayed.
>> 
>> What has changed from Fedora 10 to Fedora 11, that could cause this
>> behaviour, and what can I do to fix it?
>
> I think the vga=normal is supposed to be on the kernel line. At least
> that is where I always put my similar command vga=0x317, which creates
> a console identical to the one you don't want. :-)

I tried that too, without any difference - sorry.

>> 
>> 2. The wireless network will not start at boot time
>> 
>> The wpa_supplicant service is activated, and also the network sercice.
>> NetworkManager however, is disabled. The
>> /etc/sysconfig/network-scripts/ifcfg-wlan0 looks like this:
>> 
>> # Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection
>> DEVICE=wlan0
>> BOOTPROTO=dhcp
>> HWADDR=00:1f:3b:ad:eb:13
>> PEERDNS=yes
>> ONBOOT=yes
>> 
>> Anyway, the computer hangs for a long time while looking for IP
>> information for wlan0, and the process ends with som unsuccess on ping
>> to the dhcp's IP address. Doing 'ifup wlan0' after logging in, works.
>> 
>> Also this issue occured after upgrading the system. What can I do to
>> fix this problem?
>
> I recall someone saying something on the list about another setting,
> that ONBOOT doesn't really start the network on boot, there is
> share network connection or some other parameter you have to set
> to yes.

Hmm. Do you know the exact parameter name? Let me add that I also
tried without wpa_supplicant enabled, and exactly the same happened.

Lars



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]