[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: missing dependency



On Fri, 31 Jul 2009 10:49:37 -0700
Mike Wright <mike wright mailinator com> wrote:

> Hi all,
> 
> I've just come across this:
> 
> -> Finished Dependency Resolution
> perl-Gtk2-MozEmbed-0.08-6.fc10.2.i386 from updates has depsolving
> problems --> Missing Dependency: gecko-libs = 1.9.0.11 is needed by
> package perl-Gtk2-MozEmbed-0.08-6.fc10.2.i386 (updates)
> 
> I'd bugzilla it but I've never been able to figure out which packages 
> different things belong to.
 
You can up the debuglevel=# in /etc/yum.conf (the default is 2) to 6 or
so (max is 10) and reroute the output to a file for later perusal.  

yum update perl-Gtk2-MozEmbed-0.08-6.fc10.2.i386 > yum_output 2&>1

This will show you the dependency resolution process and allow you to
determine exactly what is causing the failure.  

less yum_output

I had a similar problem in x86_64 because I had a package
pcmanx-gtk2-xulrunner-plugin installed and it hadn't been updated when
xulrunner was.  So it wanted an earlier version of gecko-libs.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]