[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: MDRaid 1 Recovery



Recoveries just never seen simple...


On 05/02/2009 07:17 PM, Law Barstow wrote:
Hello List,

I'm having some issues with my mdraid.  The system is Fedora 10, x86_64.
I installed the system with two Seagate drives in a RAID 1
configuration.  I let the configuration utility automatically setup the
RAID configuration.  I believe each drive is configured a single
partition with this partition being part of the RAID device.

About a week ago, device 0 reported errors and was dropped from the
array by mdraid.  The RAID continued in a degraded state  with no
problems.  I finally had time to work on it so I shut down the PC and
tried to run some disk drive utilities on it.  The BIOS isn't even
seeing the drive, so I'll RMA it to Seagate.  Drive 0 is unplugged and
not in the system, leaving Drive 1.  When I try to boot, I get just a
message of "GRUB".  I'm assuming that my problem is that GRUB was
installed to drive 0 and drive 0 was set to be my primary.  

I've tried booting to the FC10 Install media in recovery mode, but when
it attempts to mount the device, I receive a message that the device
must be initialized, which will cause a loss of all data. 

How do I resolve the problem booting to drive 1?  Second, once I install
my replacement device, how do I rebuild the array?  I assume I'll need
to some how get my current Drive 1 set to primary and then install the
second drive, and use mdadm to add it. 

Thank you for your help



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]