[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

F9: Unable to get SVN/Apache working

Previous posting broken off from thread:
"F9: Eclipse plug: Subversive SVN does not work?"

I posted previously thinking that there was a problem
with eclipse/netbeans, but it was not.  I have decided
to create a new thread focusing exclusively on SVN/Apache
issues, thus this "new" posting.

To make a long story short, I have been able to get my
SVN working with the svnserve daemon and it works.
However, I am unable to get SVN/Apache to work.

My SVN repository directory structure is:
/svn --> /f-App1/Develop/SC/svn
   passwords svnauthz.conf
   [ # cat svnauthz.conf :
          home = user1.user2,user3
           * = r
           * =
           @home = rw
   svn1 svn2 svn3 svn4
     1) All selinux contexts of dir/files are: httpd_sys_content_t
     2) All directory permissions are: 2770
     3) All file permissions are: 660
4) All svn[1-4]/conf files are linked to apache/files for svnserve daemon
   authz  passwd  svnserve.conf

I have created a simple apache construct in
/etc/httpd/conf.d/subversion.conf as:
<Location /svn>
  DAV svn
  SVNParentPath /svn/repos
#   AuthzSVNAccessFile /svn/apache/svnauthz.conf
#   AuthUserFile /svn/apache/passwords
#   AuthType Basic
#   AuthName "Authorization Required"
#   Require valid-user
#   Satisfy any

Starting httpd, results in error_log as:
[Sun May 03 13:24:42 2009] [notice] caught SIGTERM, shutting down
[Sun May 03 10:24:44 2009] [notice] core dump file size limit raised to 4294967295 bytes [Sun May 03 10:24:44 2009] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0 [Sun May 03 10:24:44 2009] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) [Sun May 03 10:24:46 2009] [notice] Digest: generating secret for digest authentication ...
[Sun May 03 10:24:46 2009] [notice] Digest: done
[Sun May 03 10:24:46 2009] [notice] mod_python: Creating 4 session mutexes based on 150 max processes and 0 max threads.
[Sun May 03 10:24:46 2009] [notice] mod_python: using mutex_directory /tmp
[Sun May 03 13:24:47 2009] [notice] Apache/2.2.9 (Unix) DAV/2 mod_auth_kerb/5.3 mod_auth_pgsql/2.0.3 Line-Edit/1.0.0 mod_nss/2.2.9 NSS/ PHP/5.2.6 mod_python/3.3.1 Python/2.5.1 mod_scgi/1.13 mod_ssl/2.2.9 OpenSSL/0.9.8g SVN/1.4.6 mod_apreq2-20090110/2.7.1 mod_wsgi/2.1-BRANCH mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations [Sun May 03 13:25:11 2009] [error] avahi_client_new() failed: An unexpected D-Bus error occured

Note: I have tried to resolve the avahi_client_new() error above but unable to fix it. No response from Fedora community as to what this error might mean. I have removed all extra avahi packages, short of removing too many dependencies. So, for the moment I have ignored this error. Also, as appeared in the original posting, Apache's mod_security was reporting "errors", so I removed mod_security so that these messages do not appear for the purpose of testing and getting svn/apache setup right before adding it back in.

Tested svn using Firefox, using URL: http://localhost/svn/svn3/:
Revision 2: /

   * branches/
   * tags/
   * trunk/

Powered by Subversion version 1.4.6 (r28521).

But httpd error_log shows:
[Sun May 03 14:00:56 2009] [error] [client] Could not fetch resource information. [301, #0] [Sun May 03 14:00:56 2009] [error] [client] (84)Invalid or incomplete multibyte or wide character: Requests for a collection must have a trailing slash on the URI. [301, #0]

However, it seems to work.  I can walk down the trees to
the leafs and no further error_log messsages appear.

Next, I tested svn on the command line:
$ svn list http://gold/svn/svn3
svn: PROPFIND request failed on '/svn/svn3'
svn: PROPFIND of '/svn/svn3': 403 Forbidden (http://gold)

And httpd error_log shows:
$ svn list http://localhost/svn/svn3
svn: PROPFIND request failed on '/svn/svn3'
svn: PROPFIND of '/svn/svn3': 403 Forbidden (http://localhost)

I have at this point, tried almost every permutations of changing dir/file
permissions, relocating the repositories to: /var/www and to /var/www/html,
modifying subversion.conf, checked apache permissions (Allow from all) in
/etc/httpd/conf/httpd.conf & subversion.conf files, checked the firewalls
(they are wide open) and I could never get past the PROPFIND,
403 Forbidden problem.

I cannot think of anything else to try, so I am at a stand-still.

Can someone help?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]