[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Wireless speed drops


I'm having an odd problem with Fedora 10. I'm using the x86 version (fully updated) on Toshiba Satellite A200. My network card is Intel 3945ABG and I'm using 802.11g with WPA.

After a few minutes with this maximum speed of my home network (20-23MBps), it suddenly drops to values around 1MBps and doesn't increase again, no matter what I try. The only solution is to restart Network Manager. After deactivating NM and trying wicd, the problem persisted. And I was able to solve it by restarting wicd, like the case with NM. Some people from the Bulgarian LUG suggested that it's from iwl3945, because they have similar issues. But they don't have a solution yet. Unfortunately, I don't see anything suspicious in the logs. I tried updating the system, but it didn't help. Using some koji packages, including 2.6.29, led to the same result.

Any ideas how can I debug this issue? It isn't a big pain in my everyday use, but gets pretty annoying when I'm downloading something big. Any help will be appreciated. Thanks in advance!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]