[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Cannot find -lf2c compilation error

Paul Smith wrote:
On Tue, May 19, 2009 at 9:54 PM, Kevin J. Cummings
<cummings kjchome homeip net> wrote:
I am trying to compile a program which was written in C. (The Makefile
is shown below.) However, when I run the command 'make', I get the
following error:

$ make
... -L./f2c -lf2c -lm
/usr/bin/ld: cannot find -lf2c
You don't have to modify anything. Just:

$ cd bpmpd_c/src/f2c
$ make

which builds bpmpd_c's f2c library and after that you can

$ cd ..
$ make

as you tried.
Thanks, Jussi. Your suggestion solve the problem, but now I am getting
a another one. Please, see below.

Any ideas?
       I'm not sure what you are doing wrong, I just downloaded the .tar.gz
file, untar-ed it, went to the f2c directory and ran "make", changed back to
the src directory, and ran "make" again.  It built for me with no problems
(F9-x86_64).  You have something wrong with your development environment.

Your errors below seem to be a problem between x86 and x86_64.  Did you do
both builds on the same computer?

None, actually. My architecture is i386.

That's not what your make run says.... it says you are trying to link in some x86_64 object files....


Kevin J. Cummings
kjchome rcn com
cummings kjchome homeip net
cummings kjc386 framingham ma us
Registered Linux User #1232 (http://counter.li.org)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]