[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Globbing with scp

Todd Zullinger wrote:
Dave Feustel wrote:
There appear to be missing concluding brackets in the output of man
scp: (F9)
     scp - secure copy (remote file copy program)

     scp [-1246BCpqrv] [-c cipher] [-F ssh_config] [-i identity_file]
 [[user ]host1:]file1 ...  [[user ]host2:]file2


The missing right brackets make me wonder how to transmit
bunches of files without having to specify the password(s)
multiple times.

Huh?  The brackets are in matched pairs AFAICT.

Is globbing possible? If so, could someone provide an example? So
far none of my experiments attempting to transfer multiple files in
a single scp command have worked.

It might help if you showed a little of what you tried.  Globbing when
the files are on the localhost is easy:

   $ scp *.diff remote:/tmp

Going in the other direction requires you to quote the glob characters
to prevent them from being expanded by your local shell:

    $ scp remote:'/tmp/*.diff' .

scp -r user host:~/.emacs* .

This copied over all my emacs related stuff from the remote machine to my present working directory without any hicups. The directory structures were also preserved, and I didn't need to escape the '*'.


Open source is the future. It sets us free.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]