[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: I'd like to get rid of pulseaudio but ...

Hi Kevin,

Many thanks for your interest to my problem. Sorry, I may not have
replied as soon as you'd expect. This is because, after reading your
response and others, I tried several things which were suggested to me.

But, first, here's my problem:

My PC is quite old. It's a Compaq desktop 5100 with A Pentium II running
at 800 mHz, 512 MB of RAM and an Intel I810 audio chip.

On this PC, I first installed a fedora 9 which worked like a charm until

On the gnome desktop, I launch the "orca" screen reader which I
configured to say screen content through the ESpeak speech synthesizer.

A month ago, after a yum update, the synth began to drop last syllables
of what it had to say. For instance, "Welcome to Orca" became "Welcome
to Or".

Yesterday, I upgraded the F9 PC to F10 in order to benefit from many
enhancements of Orca and the gnome desktop from 2.22 top 2.24.

As a result, I don't hear ESpeak anymore.

I suspected pulseaudio to be the culprit after doing the following.

(1) I booted the PC in runlevel 3, (console only).

(2) I logged onto my account and issued the following command:

script -c startx

(3) After awhile, I could hear the login sound and then orca was
launched and brailled "Welcome to orca" but it did not speak. Also the
screen reader continued to braille, it did not say anything.

(4) I logged out X and then, after the X server was shut down, I was
back to the console.

(5) In the "typescript" file which was generated by "script", I read
that some actions required me to have increased RT_PRIO or RLIMIT_NICE
capabilities. It was suggested to add my user account to the "pulse-rt"

(6) I did this by logging as root and entering the command:

usermod -a -G pulse-rt <my_login>

Then I logged out from root and back in to my account.

(7) I started the gnome desktop but to no avail. Of course, I didn't
have the warning I had before but always no speech.

(8) I then logged in as root and tried to "yum erase pulseaudio". Four
dependent packages were also removed. I wrote down their names in order
to be able to reinstall them all later.

(9) I then logged out root and logged in back to my account and started
the gnome desktop. This time, I did not hear the login sound but after
awhile, I heard ESpeak saying "Welcome to orc". The synth did not finish
its sentence but it talked. Problem: This is the only sentence I could
hear. Then, orca was totally frozen: no more braille, no more speech,
just as if orca was deadlocked somewhere.

(10) I reinstalled pusleaudio and its four dependent packages and tried
to start gnome again. This time, I heard the login sound but no speech,
just like in (7).

(11) I finally tried to modify /etc/asound.conf and to create a
~/.asoundrc in my home directory, as suggested by Paulo Cavalcanti. This
time, when I started the gnome desktop, I heard the login sound, then
"Welcome to Orc", ESpeak did not finish and Orca was frozen like in (9).

Now, I realize that my problem may not be due to pulseaudio but what
should I do to have ESpeak work in F10 like it did in F9 please?

Many thanks in advance. Have a nice day. Chris

-----Original Message-----
From: fedora-list-bounces redhat com
[mailto:fedora-list-bounces redhat com] On Behalf Of Kevin Kofler
Sent: jeudi 28 mai 2009 00:14
To: fedora-list redhat com
Subject: Re: I'd like to get rid of pulseaudio but ...

Delaunay Christophe wrote:
> What the good way to get rid of pulseaudio on Fedora 10 please?

Why do you want to do that in the first place? Chances are removing
PulseAudio is not the correct solution for your problem.

        Kevin Kofler

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]