[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: f10 install, still no X [success with xdriver=vesa vga=792]

David, thanks for your suggestions re the xorg wiki

I had already tried  Xorg -configure
to generate an xorg.conf,  but that by itself not enough to boot to X

I have since found that I _can_ boot to X
I use as kernel parameters
xdriver=vesa vga=792

I had been using these for a couple of days
without success, so it is some combination of steps
that finally succeeded.

If i remove those parameters, again no booting  to X

 the first stanza in grub.conf does not boot to X;
 the second stanza does:

#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd1,7)
#          kernel /vmlinuz-version ro root=/dev/sda1
#          initrd /initrd-version.img

title Fedora ( (hd1,7)  scsi_mod.scan=sync
        root (hd1,7)
        kernel /vmlinuz- ro root=UUID=f3e0f6cf-c687-4d8e-b
08b-3a27f2f79766 rhgb quiet scsi_mod.scan=sync
        initrd /initrd-

title Fedora ( (hd1,7)scsi_mod.scan=sync vesa vga=792
        root (hd1,7)
        kernel /vmlinuz- ro root=UUID=f3e0f6cf-c687-4d8e-b
08b-3a27f2f79766 rhgb quiet scsi_mod.scan=sync xdriver=vesa vga=792
        initrd /initrd-

[I am now using a separate /boot partition sdb8,
 with f10 /  still on sda1
 but I dont think that is the issue]

more than a month ago when I was still trying to use livecd (not install)
i found then that i needed those parameters for the livecd to boot to X
but i had forgotten all about it, until I tried a few days ago
on the f10dvd install, but then it had no effect.

Somehow using those kernel parameters
coupled with my various attempts "init 5"
to get an apparently error free Xorg.0.log
and perhaps the final
startx -- :1
did the magic trick.

I cant reconstruct exact set of steps I took to  get here:
About 1 week ago, may24?
I did  Xorg -config  to generate xorg.conf.new
and copied it to /etc/X11/xorg.conf
and  redid  system-ccnfig-display -v
then "init 5"
but those steps  by itself still not booting  to X

I redid the install on may 26,
again copied the xorg.conf
and again
system-ccnfig-display -v; init 5
still no X

startx -- :1
but it gave DRM errors in Xorg.1.log:

[root localhost log]# ls -l X*
-rw-r--r-- 1 root root 40137 2009-05-28 07:17 Xorg.0.log
-rw-r--r-- 1 root root 40677 2009-05-28 07:16 Xorg.0.log.old
-rw-r--r-- 1 root root 38695 2009-05-27 03:55 Xorg.1.log
-rw-r--r-- 1 root root   835 2009-05-26 12:26 Xorg.setup.log
[root localhost log]# grep EE Xorg.1.log

(EE) MGA(0): [drm] Could not boot-strap DMA (-16)
(EE) MGA(0): failed to destroy server context
[root localhost log]#

same msg in Xorg.setup.log

evidently those EE
not preventing X
or those EE no longer in effect.

Summary: for my system with the f10dvd
i need
xdriver=vesa vga=792

Can anyone  tell me why these necessary
and/or where documented?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]