[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: WUSB54G firmware

Jim wrote:
On 05/31/2009 02:21 AM, Paulo Cavalcanti wrote:

On Sat, May 30, 2009 at 10:47 PM, Jim <mickeyboa sbcglobal net <mailto:mickeyboa sbcglobal net>> wrote:


    I'm trying to setup a Linksys WUSB54G and I get this error message
    from DMESG.

    usb 2-2: firmware: requesting l3886usb

    usb 2-2: (p54usb) cannot find firmware (isl3886usb)

    usb 2-2: firmware: requesting isl3890usb

    p54usb: probe of 2-2:1.0 failed with error -2
    usbcore: registered new interface driver p54usb

    I have googled isl3886USB and can't find the firmware, does anyone
    know where this firmware

I am pretty sure I used one of those on F8, and it worked out of the box.

Anyway, take a look at


which will take you to:


Paulo Roma Cavalcanti
I should have told you that I'm trying install on a X86_64 box.

I did install the and it is in /lib/firmware, it would not install in

I think I need to install the ndiswrapper for i386, I have ndiswrapper.X86_64 installed.

The ndiswrapper.i386 doesn't show up in FC10 X86_64 fedora repo how do I change the repo's to read the i386 files ?

I think you missed a crucial step. Although right now I am using a D-Link USB wifi receiver, I did try a Linksys for a few days after I had set it up for the D-Link, and it worked right out of the box. So the procedure should be the same. Here is how I did it for the D-Link.

1. I put the firmware in /lib/firmware/
2. Renamed it to 'isl3890usb'
2. in /lib/modules/`uname -r`/build/ ran "make menuconfig" as root, enabled the relevant kernel module. then did a "modprobe <driver>". Here <driver> is p54.

I believe you missed the renaming the firmware part.


PS: I am on x86_64 too
$uname -r


Open source is the future. It sets us free.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]