[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F11 - X forwarding display problem

Gordon Messmer wrote:
On 05/31/2009 10:53 AM, John Foisy wrote:
I've already tried the -Y option with no results. Here
is the content of the pertinent section of sshd_config:

That's odd.  I have two machines running F11 with all of the updates, and X11 forwarding between them works just fine with both -X and -Y.

>From one of the F11 hosts, log in to the other with:
 ssh -v <f11host> -X

Once you're logged in, check the X cookie file:

Finally, try a simple X11 application:

If it doesn't work, send the output of all of the commands.

Hi Gordon,
I tried your suggestion and it did'nt work. Here is the output:

[john LT-02 ~]$ ssh -v LT-01 -X
OpenSSH_5.1p1, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to LT-01 [] port 22.
debug1: Connection established.
debug1: identity file /home/john/.ssh/identity type -1
debug1: identity file /home/john/.ssh/id_rsa type 1
debug1: identity file /home/john/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.2
debug1: match: OpenSSH_5.2 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'lt-01' is known and matches the RSA host key.
debug1: Found key in /home/john/.ssh/known_hosts:7
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-with-mic,password
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure.  Minor code may provide more information
No credentials cache found

debug1: Unspecified GSS failure.  Minor code may provide more information
No credentials cache found

debug1: Unspecified GSS failure.  Minor code may provide more information

debug1: Next authentication method: publickey
debug1: Offering public key: /home/john/.ssh/id_rsa
debug1: Server accepts key: pkalg ssh-rsa blen 277
debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions openssh com
debug1: Entering interactive session.
debug1: Requesting X11 forwarding with authentication spoofing.
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
Last login: Sun May 31 14:45:58 2009 from lt-02.localdomain
[john LT-01 ~]$ ls -lZ $XAUTHORITY
drwxrwxr-x. john john unconfined_u:object_r:user_home_t:s0 bin
drwxr-xr-x. john john unconfined_u:object_r:user_home_t:s0 Desktop
drwxr-xr-x. john john unconfined_u:object_r:user_home_t:s0 Documents
drwxr-xr-x. john john unconfined_u:object_r:user_home_t:s0 Download
drwxrwxr-x. john john unconfined_u:object_r:user_home_t:s0 DT-01
drwxrwxr-x. john john unconfined_u:object_r:user_home_t:s0 LT-02
drwxr-xr-x. john john unconfined_u:object_r:user_home_t:s0 Music
drwxr-xr-x. john john unconfined_u:object_r:user_home_t:s0 Pictures
drwxr-xr-x. john john unconfined_u:object_r:user_home_t:s0 Public
-rw-rw-r--. john john unconfined_u:object_r:user_home_t:s0 smolt-LT-01
-rw-rw-r--. john john unconfined_u:object_r:user_home_t:s0 smolt-LT-01~
drwxr-xr-x. john john unconfined_u:object_r:user_home_t:s0 Templates
drwxr-xr-x. john john unconfined_u:object_r:user_home_t:s0 Videos
[john LT-01 ~]$ gedit

(gedit:2402): Gtk-WARNING **: cannot open display: localhost:11.0
[john LT-01 ~]$

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]