[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Fedora-livecd-list] persistence testing howto



WARNING: THE FOLLOWING IS A VERY ALPHA EXPERIMENTAL DEVELOPMENT FEATURE

If you have to ask what this is all about, it isn't ready for your testing yet. Please wait a bit longer.

More variations of this on the way for testing purposes, but for the
moment, this might work-

(actually it seems to work better than I thought it would, see notes below)

# get the 5MB binary delta blob
wget \
http://filteredperception.org/downloads/overlay/20071216/Fedora-8-Live-i686.persistence.xdelta

# get the f8 livecd iso, or use existing and modify commands accordingly
wget \
ftp://mirrors.kernel.org/fedora/releases/8/Live/i686/Fedora-8-Live-i686.iso

# this generates the patched iso
xdelta patch \
Fedora-8-Live-i686.persistence.xdelta \
Fedora-8-Live-i686.iso \
Fedora-8-Live-i686.persistence.iso

# this extracts the modified livecd-iso-to-disk
isodump -R -i Fedora-8-Live-i686.persistence.iso \
-x /LiveOS/zyx-livecd-iso-to-disk \
zyx-livecd-iso-to-disk

chmod +x ./zyx-livecd-iso-to-disk

# assuming /dev/sdb is a usb flash drive that you have previously tested
# with livecd-iso-to-disk and been able to boot, and has a single
# /dev/sdb1 partition with a uuid and no fslabel

./zyx-livecd-iso-to-disk \
--reset-mbr \
--overlay-size-mb 128 \
./Fedora-8-Live-i686.persistence.iso \
/dev/sdb1

# and give it a whirl...

note: the following sha1sum will merely tell you that the file you
receive is likely the same one that I created on my internet connected
development system.  While I give my word that I have not knowingly
introduced any trojans or security holes, I urge you to assume that
other hackers who have infected my system have.  Though on the plus
side, experimental livecds are some of the easiest pieces of untrusted
software to safely test.  (i.e. you can test them on systems with no
hard drive that you would need to worry about possibly corrupting)

sha1sum Fedora-8-Live-i686.persistence.xdelta
924146b62546fa2342023a1f614da5eb155e318b

note that the bit about the uuid and no fslabel is due to the fact that
I didn't realize that livecd-iso-to-disk worked with fslabels instead of
uuids until tonight.  I'll fix that limitation soon.  I ran into a fresh
2G flash with a single vfat fs, and no uuid, and was able to create one
by just running 'mkfs.vfat /dev/sdb1'.  Unfortunately for some bizarre
reason this 2G one won't boot my laptop, but a 1G model from the same
product line does...???  hence the bit about making sure you have tested
with stock f8 and stock livecd-iso-to-disk.

note, that despite everything I've said about it being fragile WRT unclean shutdown... I've noticed a couple things while putting this download together. A) since I last worked with it a couple months ago, something is screwing up the clean shutdown, so don't be alarmed when you see a message on shutdown that it failed to remount readonly the overlayfs. and B) in rudimentary testing, I persisted across 3 reboots, the 2nd of which was a unclean poweroff instead of a clean shutdown. Not that a sample size of 1 proves anything, but before my sample size of 1 was an unrecoverable corruption... go figure.

More to come...  If you bother to test, please report success or failure.

Thanks,

-dmc/jdog




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]