[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmlint and Obsoletes: loops



On Fri, 2006-07-21 at 10:22 +0200, Florian La Roche wrote:

> While it is most times a good idea to add the "Provides:"
> lines for all obsoletes as well, we should not just add them
> to all of them. Especially not if nobody found them missing
> for many years by now.

Note that when using properly versioned Obsoletes/Provides [0], loops
involving those are almost nonexistent.  Unversioned Obsoletes/Provides
is pretty rarely the right thing to do, as they match *all* versions.

And of course, if the thing obsoleted is not actually provided in a
compatible way by the new package but is just made obsolete by it, the
provides shouldn't be added at all.

[0] eg. Provides:  foo = %{version}-%{release}
        Obsoletes: foo < $first_V-R_where_above_provides_appeared


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]