[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Downgrading OpenSceneGraph in rawhide?



Hi,

Is it possible to downgrade a package or replace a package with an older
version in rawhide without having to bump the epochs?


Background

Short version:

I plan to replace OpenSceneGraph-2.0 with OpenSceneGraph-1.x and to add
a OpenSceneGraph2 package in rawhide (similar to what gtk did during the
gtk-1 -> gtk-2 transition), due to other packages still carrying deps on
OpenSceneGraph-1.x


Longer version:

I pushed OpenSceneGraph-2.0 into rawhide (API/ABI/SONAME wise completely
incompatible to OpenSceneGraph-1.x (as currently in FC-7)

Unfortunately, for various reasons, other packages have not been/have
not been able to upgraded to OpenSceneGraph-2.0, so far. This forces me
to continue shipping OpenSceneGraph-1.x and OpenSceneGraph-2.0.

Now, I am planning to introduce an OpenSceneGraph2 package (a modified
version of the OpenSceneGraph package currently in Rawhide) and to
replace OpenSceneGraph with a modified version of the OpenSceneGraph
package in FC-7.

Both packages's runtime-packages would be modified to be installable in
parallel, but the *-devel packages would likely conflict.

Ralf






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]