[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Downgrading OpenSceneGraph in rawhide?



On Fri, 2007-08-24 at 19:46 +0530, Rahul Sundaram wrote:
> Ralf Corsepius wrote:
> > Hi,
> > 
> > Is it possible to downgrade a package or replace a package with an older
> > version in rawhide without having to bump the epochs?
> > 
> > 
> > Background
> > 
> > Short version:
> > 
> > I plan to replace OpenSceneGraph-2.0 with OpenSceneGraph-1.x and to add
> > a OpenSceneGraph2 package in rawhide (similar to what gtk did during the
> > gtk-1 -> gtk-2 transition), due to other packages still carrying deps on
> > OpenSceneGraph-1.x
> > 
> 
> Couldn't you introduce a package named OpenSceneGraph1-x.y?
No, this package name would be backward incompatible to FC-7.

>  It would be 
> inconsistent with the packaging naming prevalent in the repository but 
> it can be a way to avoid disrupting the existing packages and 
> introducing epochs.

We are talking about rawhide.

Ralf



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]