[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Downgrading OpenSceneGraph in rawhide?



On Fri, 2007-08-24 at 16:43 -0400, Ignacio Vazquez-Abrams wrote:
> On Fri, 2007-08-24 at 16:41 +0200, Ralf Corsepius wrote:
> > On Fri, 2007-08-24 at 19:46 +0530, Rahul Sundaram wrote:
> > > Couldn't you introduce a package named OpenSceneGraph1-x.y?
> > No, this package name would be backward incompatible to FC-7.
> 
> How so?
> 
> Name: OpenSceneGraph1
> ...
> Obsoletes: OpenSceneGraph < 2
This would only work for the run-time packages, but would not work for
the devel packages.

> Packages depending on OSG1 and OSG should be pulling in by library, not
> package name anyways, correct?
No, the problem is the *-devel packages:
BuildRequires: OpenSceneGraph-devel

Those packages which current break, expect OpenSceneGraph-devel to
contain OSG-1 packages.

Ralf



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]