[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Server-devel] Revisor / yum odd error with f9 updates.newkey repo: Missing Dependency: glibc-common = 2.8-3 is needed by package glibc-2.8-3.i386



On Tue, Oct 14, 2008 at 4:23 AM, seth vidal <skvidal fedoraproject org> wrote:
>> The error is
>>   Missing Dependency: glibc-common = 2.8-3 is needed by package
>> glibc-2.8-3.i386
>
> Is there any other debug information available?
>
> _something_ is pulling in glibc-2.8-3 instead of 2.8-8. That's what's
> horking the issue with 2.8-3, most likely.
>
> But without more debugging info I'm hard pressed to tell you what's
> happening.

Can't get revisor to give me a separate yum log at the moment, but I
managed to get yum into high-debug mode. So the messages are mixed
between revisor and yum, but it seems to make sense:

   http://dev.laptop.org/~martin/revisoryum.log.bz2

It definitely sees 2.8-8, and I can't spot anything that calls
glibc-2.8-3 *except* that there's a mention of it being included "from
Groups" --

Including glibc
>From Groups: Adding glibc-0:2.8-8.i686 to transaction
>From Groups: Adding glibc-0:2.8-8.i386 to transaction
>From Groups: Adding glibc-0:2.8-3.i386 to transaction
>From Groups: Adding glibc-0:2.8-3.i686 to transaction

and later 2.8-3 wants the matching glibc-common, which *is* in the
repo. However, yum doesn't like it and it doesn't settle for the 2.8-8
set.

Do the logs make sense to you?

Also -- I did add glibc and glibc-common explicitly to the kickstart
file, but it didn't make a difference.

cheers,



m
-- 
 martin langhoff gmail com
 martin laptop org -- School Server Architect
 - ask interesting questions
 - don't get distracted with shiny stuff  - working code first
 - http://wiki.laptop.org/go/User:Martinlanghoff


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]