[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: joyride 2514 vs rawhide



No problems at all, just let me know how i can take this forward and I
can run with it to get the easy stuff merged mainline.

Peter

> Peter, this is brilliant work.  Thank you.
>
> --g
>
> On Sun, 12 Oct 2008, Peter Robinson wrote:
>
>> Hi All,
>>
>> Having had a bit of time over the weekend while on call for work I did
>> some comparisons between packages in rawhide and those in joyride [1]
>> to see what had been merged upstream like what was done back in August
>> or so. The was I worked it out was just a basic grep to remove .fc9
>> packages as to see what was left. The first 3 sections are easy fix
>> and mostly either the package isn't in Fedora (first section), is
>> using a branch that's not in Fedora cvs (is there a cvs for OLPC
>> packages) or ones that are easy to merge with mainline.
>>
>> It looks like 8.2.0 release is now done so the fixes would be going
>> towards 9.1 one at a guess, and I suspect some of this will be
>> dependent on whether its based on F-9 still or F-10.
>>
>> Anyway, I'm not sure if the info below is useful. Sections 3 and 4
>> (and at least some in section 2) should be fairly simple to get
>> aligned with mainline fedora devel, and probably pushed to F-9 as well
>> if necessary. I can look to get this done if it would be helpful but
>> if its not I don't want to waste time on it. If so let me know. I
>> think the process would be essentially get any changes/fixes if
>> necessary into mainline and the get joyride to pull the mainline
>> package in rather than the branch. Once that's done the branch would
>> then get marked as dead. So let me know if its a help and if someone
>> wants me to do further.
>>
>> Peter
>>
>> 1 - Not in Fedora
>> Mothanna-fonts,0.02-3.olpc3 - awaiting review - RHBZ 462711
>> bootfw,q2e19-1.olpc2.unsigned - no review bug
>> cerebro,2.9.16-1.olpc3 - no review bug
>> ds-backup-client,0.8.1-1.olpc3 - no review bug
>> squeak-vm,3.10-3olpc11 - no review bug
>> olpc-contents,2.5-1 - no review bug
>> olpc-library-common,1-31 - no review bug
>> olpc-licenses,8.2.0.0-1.olpc3 - no review bug
>> olpcrd,0.48-0 - no review bug
>> olpcsudo,1.4-1 - no review bug
>> olpc-update,2.17-1 - no review bug
>>
>> 2 - No OLPC branch in Fedora CVS (not sure where to find them)
>> numpy,1.1.1-1.olpc3.1 - no olpc3 branch
>> libX11,1.1.4-3.olpc3 - no olpc3 branch but an olpc2 one
>> python,2.5.1-26.olpc3.1 - no branch
>> yum,3.2.19-3.1.olpc3 - no branch
>>
>> 3 - Forked but essentially the same, original fork fixed etc
>> gstreamer-python,0.10.7-2.olpc3.1 - NO DIFF (prob dep on newer vers of
>> other gst packages)
>> hulahop,0.4.6-4.olpc3 - identical - suspect needs xulrunner python
>> which is now upstream so can merge
>> libertas-usb8388-firmware,2:5.110.22.p18-1.olpc2 - upstream although
>> slightly older ver p14 vs 18 - should push new ver upstream and merge
>> - no OLPC branch
>> ntp-ntpdate,4.2.4p4-7.olpc3 - adds keys and step-tickers (looks like
>> should be merged with upstream)
>> ohm,0.1.1-6.21.20080921git.olpc3 - no upstream devel - OLPC branch
>> just needs to be moved into head
>> olpc-utils,0.89-1.olpc3 - original import in devel, just need to merge
>> changes to mainline
>> olpcsound,5.08.92-11.olpc3 - fork of csound so is exclusive to  olpc
>> but no reason not to merge to mainline
>> pyabiword,0.6.1-4.olpc3 - identical (suspect due to abiword fork but
>> should work fine as only abiword diff is a perl file removed for dep)
>> sugar,0.82.9-3.olpc3 - Same but a later build in OLPC
>> sugar-artwork,0.82.3-1.olpc3 - Identical
>> sugar-datastore,0.82.1-1.olpc3 - Same but two conflicting changes in
>> devel vs OLPC but easy to merge disparate changes
>> sugar-journal,99-4.olpc3 - Same but a later build in OLPC
>> sugar-toolkit,0.82.11-6.olpc3 - Same but a later build in OLPC
>> xorg-x11-utils,7.4-2.olpc3 - issue for branch (deps) has been fixed so
>> can be merged with mainline
>>
>> 4 - Forked but fixed with simple fix
>> pygtk2,2.12.1-6.olpc3.1 - Only a patch to use numpy instead of
>> numeric. Not sure if numpy support is in the 2.13 release in rawhide
>> libabiword,1:2.6.4-6.olpc3 - removes perl - will be fixed in 2.6.5 RHBZ #
>> 463924
>> pygame,1.8.0-1.olpc3.3 - OLPC package has an added "Requires:
>> SDL_Pango" without the buildreq but no other diff should be merged U/S
>> xkeyboard-config,1.3-4.olpc3 - patches for different language
>> keyboards. 1 is already in devel so probably can merge with mainline
>> and move patches there (do these patches also need to be submitted for
>> upstream) as it would affect Fedora on OLPC too.
>>
>> 5 - Forked for features
>> gnome-python2,2.22.1-3.olpc3 - disables bonobo
>> gnome-vfs2,2.22.0-3.olpc3 - remove gnome-mount req
>> gstreamer,0.10.12-3.olpc3 - removes docs - could they be split out to
>> a docs package? also a very old version - v12 vs 21
>> gstreamer-plugins-base,0.10.12-4.olpc3.4 - removes docs and
>> cdparanoia, adds gnomevfs (upstream moved to gio?)
>> gstreamer-plugins-good,0.10.5-7.olpc3.1 - removes docs, old version
>> gnash,0.8.3-1.olpc3.2 - deps
>> hal,0.5.11-2.olpc3.1 - adds a patch to disable batt polling
>> hal-info,20080607-1.olpc3.1 - adds battery-fdi.patch to disable batt
>> polling
>> initscripts,8.76.2-1.olpc3.7 - no idea! jkatz knows what's needed I think
>> kernel,2.6.25-20080925.1.olpc.f10b654367d7065 - no idea!
>> NetworkManager,1:0.6.5-0.11.svn3246.olpc3 - mesh patches. Is there an
>> upstream BZ for this?
>> poppler,0.6.2-5.olpc3 - disables gtk-test, abiword and splash output,
>> random spec updates
>> SDL_mixer,1.2.8-8.olpc3.1 - Drops req on timidity++-patches
>> sugar-evince,2.20.1.1-4.olpc3 - issue of old evince branch with new
>> poppler. Test packages using a merge from upstream evince in
>> olpc#7615telepathy-gabble,0.7.6-4.olpc3 - patch to disable security
>> telepathy-salut,0.3.3-8.olpc3 - patch to disable security
>> totem,2.23.4-1.olpc3.6 - due to t-p-p dep issues plus other deps
>> totem-pl-parser,2.23.2-2.olpc3 - dependency issues with e-d-s
>> upstart,0.3.9-19.olpc3.1 - old version, patch to run as PID other than
>> 1 - jkatz knows?
>> xorg-x11-server-common,1.4.99.906-2.olpc3.4 - Looks like difference is
>> a patch so it don't abort if mesa swrast library is not found
>> xulrunner,1.9.0.2-2.olpc3 - remove deps + some specific patches
>> (pyxpcom now enabled upstream)
>>
>> [1] http://dev.laptop.org/~rwh/announcer/stream_data/joyride/2514.pkgs
>>
>> _______________________________________________
>> Fedora-olpc-list mailing list
>> Fedora-olpc-list redhat com
>> https://www.redhat.com/mailman/listinfo/fedora-olpc-list
>>
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]