soasXO builds for USB?

Martin Dengler martin at
Mon Nov 2 08:27:20 UTC 2009

On Sun, Nov 01, 2009 at 09:27:10PM -0800, Yioryos Asprobounitis wrote:
> Thank you.

> However I was referring to the
> builds specifically
> where you have only tree.tar.lzma versions.

Ah yes.

Sebastian, can you copy the 2/4g removable images from the buildslave
as well?

How about I add a "dist" target to the makefile that does this?

> Trying these with the instructions mentioned bellow failed miserably
> (tried soas01xo and soas02xo)

As you pointed out, the instructions are for the *removable*.tar.lzma.
Other files won't work with the verbatim instructions.

> Expanding their content in an ext3 formatted stick also failed boot.

Actually that should work, since OFW doesn't need anything but
/boot/olpc.fth to exist in the first partition (as long as that
partition is readable by OFW, like ext3).  So I'm not sure what went
wrong for you.

> I could try the newer soas04xo.tree.tar.lzma but pls specify 

> a) Is this a device images? If yes what size?

No.  It should work if you untar it into the root of a ext3 USB stick,
though, like:

cd /media/myusbstick
lzma -dc /path/to/soas04xo.tree.tar.lzma - | tar xf -

> b) If not device images but indeed tree [...] do they need anything
> "special"?

See above.

> are devices build with their content know to boot the XO-1?.

I haven't tried that build itself on any sticks.  But I don't know of
any reason why it shouldn't work.  I'm happy to fix any problems
anyone finds.

> Thanks

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <>

More information about the Fedora-olpc-list mailing list