[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-packaging] PHP packaging policy notes



chris stone gmail com ("Christopher Stone") writes:

>> > ES> Such Requires: do not make sense nowadays. The ability to require
>> > ES> a special program version was removed some time ago from rpm.
>> >
>> > Unfortunately I can't quite parse what Enrico has written here; it
>> > looks like that statement indicates that versioned requirements don't
>> > work in RPM, which I don't think is the case.
>> >
>> > Enrico, could you (or anyone else who understands the issue) elaborate
>> > a bit?
>> ...
> Okay, now I'm _really_ confused.  So you are saying rpm can handle
> epochs properly now?

No


> That's great, so why should we remove version requirements from our
> spec files now that rpm properly handles epochs?

Ok; a more realistic example: you have an application for Fedora
Extras which requires bind, version 9.3 or later.  What would you
write?

a) Requires: bind >= 9.3?
b) Requires: bind >= 24:9.3?

When your answer is a): this requirement would be fulfilled by FE3 with
its bind 9.2.1 too, so this answer would be wrong.

When your answer is b): what would you gain with it? Epochs are a
per-environment thing and not bound to program versions. E.g. SuSE or
Mandriva might have bind-1:9.4 packages. Because the Fedora Extras
packages are for a specific environment (FE4, FE5, devel) only, you
can be sure that the needed program versions are available there and
the explicit version is not needed.




Enrico

Attachment: pgpXifExmSCjB.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]