[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-packaging] PHP packaging policy notes



On 7/5/06, Enrico Scholz <enrico scholz informatik tu-chemnitz de> wrote:
Ok; a more realistic example: you have an application for Fedora
Extras which requires bind, version 9.3 or later.  What would you
write?

a) Requires: bind >= 9.3?
b) Requires: bind >= 24:9.3?

When your answer is a): this requirement would be fulfilled by FE3 with
its bind 9.2.1 too, so this answer would be wrong.

When your answer is b): what would you gain with it? Epochs are a
per-environment thing and not bound to program versions. E.g. SuSE or
Mandriva might have bind-1:9.4 packages. Because the Fedora Extras
packages are for a specific environment (FE4, FE5, devel) only, you
can be sure that the needed program versions are available there and
the explicit version is not needed.

The answer is a.  If it doesn't work on FE3 then I would be surprised,
and it should be fixed by the legacy team for FE3.

Why would you ever use b?  I think you might be confused on the
versioning, you do realize that a version of 9:3 is different than a
version of 9.3 correct?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]