[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-packaging] PHP packaging policy notes



On Wed, 2006-07-05 at 11:53 -0700, Christopher Stone wrote:
> On 7/5/06, Enrico Scholz <enrico scholz informatik tu-chemnitz de> wrote:
> > Ok; a more realistic example: you have an application for Fedora
> > Extras which requires bind, version 9.3 or later.  What would you
> > write?
> >
> > a) Requires: bind >= 9.3?
> > b) Requires: bind >= 24:9.3?
> >
> > When your answer is a): this requirement would be fulfilled by FE3 with
> > its bind 9.2.1 too, so this answer would be wrong.
> >
> > When your answer is b): what would you gain with it? Epochs are a
> > per-environment thing and not bound to program versions. E.g. SuSE or
> > Mandriva might have bind-1:9.4 packages. Because the Fedora Extras
> > packages are for a specific environment (FE4, FE5, devel) only, you
> > can be sure that the needed program versions are available there and
> > the explicit version is not needed.
> 
> The answer is a.  If it doesn't work on FE3 then I would be surprised,
> and it should be fixed by the legacy team for FE3.

Supposing the latest FC3 bind package is 20:9.2.4 (I'll trust Enrico on
that). To the best of my knowledge there is no security or serious bug
in that version and therefore nothing for the Legacy team to concern
themselves with.

As far as rpm is concerned, version 20:9.2.4 is newer than version 9.3
(i.e. 0:9.3) and hence would satisfy a dependency of:

Requires: bind >= 9.3

However, the pacakge using this would not build/work because it actually
requires version 9.3 or later, which version 9.2.4 is not.

> Why would you ever use b?

To make sure that the problem just described did not happen.

> I think you might be confused on the
> versioning, you do realize that a version of 9:3 is different than a
> version of 9.3 correct?

Who said anything about 9:3?

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]