[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-packaging] PHP packaging policy notes



chris stone gmail com ("Christopher Stone") writes:

> oops I'm sorry, bind uses an epoch of 30 for FE5 these days, Enrico
> said it used an epoch of 0 today (or that is how I intrepreted his
> message).

Complete posting/subthread was about the

| Requires: bind >= 9.3

I never said that the bind-30:9.3.2-20 package from FC5 would be
interpreted as an epoch 0.

'Today' means current rpm; previous rpm version tried to add an implicit
epoch when an epoch'ed and a non-epoch'ed package were compared. With
previous rpm versions, the 'Requires:' above would be _read_ as

| Requires: bind >= [30:]9.3

when _compared_ with bind-30:9.3.2-20 or as

| Requires: bind >= [20:]9.2.4

when _compared_ with bind-20:9.2.4-2.


But this implementation was buggy and stored the implicit epoch in
the rpm database when package was updated (afair) which was causing
lot of problems. Algorithm was replaced by a missing-epoch == epoch-0
assumption.



> Requires: bind >= 30:9.3

ok; now we are back at

>>>>>> b) Requires: bind >= 24:9.3?
>>>>>> ...
>>>>>> When your answer is b): what would you gain with it?...




Enrico

Attachment: pgpjPVyTQixVI.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]