[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-packaging] PHP packaging policy notes

On Thu, 2006-07-06 at 13:42 -0700, Christopher Stone wrote:
> On 7/6/06, Toshio Kuratomi <toshio tiki-lounge com> wrote:
> > You are adding requirements for package versions which are not relevant
> > for Fedora, which is what the guidelines are saying should be avoided.
> How is it not relevant?  If I use FC4 and a pear pacakge I want is on
> FC5, should not installing the FC5 package do some version checking or
> are we to assume that every fedora user is using only packages from
> their distro release?
The message that this all stems from is here:
the quotation by you is that you are requiring php >= 4.2.0 in some
packages; php >= 4.3.0 in others.  php 4.3.3 was already present in
Fedora Core 1 so the package version is deeply irrelevant for Fedora.

> >
> > 3) The packaging guidelines already state when it is appropriate to
> > include versioned dependencies and this is not one of them.  This means
> > we're deciding whether to make an exception for php/pear packages rather
> > than making new policy.
> No. The packaging guidelines indicate when you should NOT use version
> numbers specifically saying not to use them if the package they refer
> to is older than redhat 6.2 which is pretty old.  Oh and not to add
> the just for fun.
> Unless there is some other text you are referring to?  We are not
> deciding to make an excption to any rules.
I'm sorry, your interpretation of the guideline is wrong.  You're
confusing the example with the rule:
  First, if the lowest possible requirement is so old that nobody has a
  version older than that installed on any target distribution release,
  there's no need to include the version in the dependency at all.  In
  that case we know the available software is new enough. For example,
  the version in gtk+-devel 1.2 dependency above is unnecessary for all
  Red Hat Linux distributions since (at least) release 6.2.

The rule is whether the lowest version requirement is satisfied by the
packages on Fedora's target distributions.  It may be open to
interpretation whether "target distribution release" means non-EOL
distributions (in which case FC4+ currently) or distributions the
packager is actively building for but in either case, php >= 4.2.0 being
irrelevant even for FC1 means it is too old.

Thanks for your well-reasoned rebuttals to Enrico's points.  I'll
continue to read them until I have an opinion on whether putting
unnecessary versions into the package spec is justified.


Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]