[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fedora-packaging] PHP packaging policy notes



On Fri, 2006-07-07 at 00:22 +0200, Enrico Scholz wrote:

> Again: versioned dependencies like "php >= 4.2" are redundant and do not
> achieve the wanted effect of requiring a program version (which is not
> supported by rpm).

Sure it is.  Just add the program version you want, eg. something like
"Provides: foo(upstream) = $upstream_version" (no Epoch, most likely no
Release) to packages and start using it.  Or maybe even change rpmbuild
to do it automatically so that for every N = E:V-R package, "Provides:
N(upstream) = V" is inserted if this is something people would find
generally useful.

> Dependencies like "php >= 4.2" are just for fun.

Again, depends.  In this case those would be useful for folks working
with Fedora and RHEL 2.1 (which continues to be supported still for
almost 3 years and has php 4.1.2).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]