[Fedora-packaging] Conflicts Draft Proposal

Bill Nottingham notting at redhat.com
Thu Jan 11 04:57:53 UTC 2007

Jesse Keating (jkeating at redhat.com) said: 
> What about the situation where Foo conflicts with bar <= 1.0, but Foo doesn't 
> require bar to run?  A Requires: bar > 1.0 doesn't work here, can a conflicts 
> be used in this case?  Is this an acceptable situation for the list at the 
> bottom of the page?

So, my usual pile of examples would be:

Conflicts: ipw2200-firmware < 2.4

i.e., if you're using this kernel with ipw2200, you need at least that
level of firmware.

Conflicts: xorg-x11 (essentially, with xorg-not-in-/usr
Conflicts: kernel < 2.6.12 (requires at least that new of a kernel)

and so on.


More information about the Fedora-packaging mailing list