[Fedora-packaging] %doc and %attr problems

Paul Howarth paul at city-fan.org
Mon Sep 22 15:03:30 UTC 2008

François Kooman wrote:
> Hi,
> I'm trying to package globalplatform and gpshell but have some problems 
> now with packaging some of the example scripts included. They are 
> chmodded 755 instead of the wanted 644 so I tried to use this in the 
> spec file:
> %attr(0644,root,root)%doc README COPYING.LESSER *.txt
> But this will result in the /usr/share/doc/gpshell-1.4.2/ also being 
> chmodded 644 which will make rpmlint (correctly) complain:
> gpshell.x86_64: E: non-standard-dir-perm /usr/share/doc/gpshell-1.4.2 0644
> I tried using:
> %doc
> %attr(0644,root,root)%doc README LICENSE.LESSER *.txt
> but that doesn't seem to help much.
> I've already submitted this issue upstream and the maintainer said that 
> he'll fix it for the next release in a few months...
> How can I deal with it best for now?

chmod the files in %prep


More information about the Fedora-packaging mailing list