Missing perl modules needed by spamassassin-3.1.0

Paul Howarth paul at city-fan.org
Mon Jul 18 09:53:51 UTC 2005


Warren Togami wrote:
> Paul Howarth wrote:
> 
>> Warren Togami wrote:
>>
>>> Anybody have made their own personal perl module package for any of 
>>> these?
>>>
>>> Warren Togami
>>> wtogami at redhat.com
>>>
>>> *************************************************************************** 
>>>
>>> NOTE: the optional Mail::SPF::Query module is not installed.
>>>
>>>   Used to check DNS Sender Policy Framework (SPF) records to fight email
>>>   address forgery and make it easier to identify spams.
>>
>>
>>
>> Yes: http://www.city-fan.org/ftp/contrib/perl-modules/SRPMS/
>>
>> Would need some cleaning up for inclusion in Core/Extras. Not a big 
>> job. Would also need some other dependency modules to be done.
>>
>> perl(Net::CIDR::Lite)
>> perl(Net::DNS) >= 0.46 for distros with older versions
> 
> 
> Be very careful about perl-Net-DNS.  I've seen lots of complaining on 
> spamassassin lists about the latest version(s) being reportedly broken.

I know (though as a spamassassin user myself now, I haven't actually 
noticed any issues with 0.52).

Mail::SPF::Query does have an explicit dependency on perl(Net::DNS) >= 
0.46 though, and FC < 3 have older versions than that.

Paul.




More information about the Fedora-perl-devel-list mailing list