[Bug 167354] Review Request: amavisd-new

bugzilla at redhat.com bugzilla at redhat.com
Fri Jan 20 06:54:29 UTC 2006


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: Review Request: amavisd-new


https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167354


paul at xtdnet.nl changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |paul at xtdnet.nl




------- Additional Comments From paul at xtdnet.nl  2006-01-20 01:54 EST -------

when updating from your first to your last rpm, I noticed amavisd is restarted
twice:

[root at cdc ~]# rpm -Uhv /usr/src/redhat/RPMS/noarch/amavisd-new-2.3.3-4.noarch.rpm
Preparing...                ########################################### [100%]
   1:amavisd-new            warning: /etc/amavisd/amavisd.conf created as
/etc/amavisd/amavisd.conf.rpmnew
########################################### [100%]
Shutting down amavisd: Can't SIGTERM amavisd[1337]: No such process at
/usr/sbin/amavisd line 8983., can't stop the process
[FAILED]

Starting amavisd: Pid_file "/var/run/amavisd/amavisd.pid" already exists. 
Overwriting!
[  OK  ]

Stopping clamd.amavisd: [  OK  ]
Starting clamd.amavisd: [  OK  ]
[root at cdc ~]#

More importantly, amavisd never starts for me. It goes through a lot of good
messages and then ends with an error:
Jan 20 01:54:19 cdc amavis[1588]: Found decoder for    .zoo  at /usr/bin/zoo
Jan 20 01:54:19 cdc amavis[1588]: Found decoder for    .lha  at /usr/bin/lha
Jan 20 01:54:19 cdc amavis[1588]: Found decoder for    .cab  at /usr/bin/cabextract
Jan 20 01:54:19 cdc amavis[1588]: No decoder for       .tnef tried: tnef
Jan 20 01:54:19 cdc amavis[1588]: Internal decoder for .tnef
Jan 20 01:54:19 cdc amavis[1588]: Found decoder for    .exe  at /usr/bin/unrar;
/usr/bin/lha; /usr/bin/unarj
Jan 20 01:54:19 cdc amavis[1588]: Using internal av scanner code for (primary)
ClamAV-clamd
Jan 20 01:54:19 cdc amavis[1588]: Found secondary av scanner ClamAV-clamscan at
/usr/bin/clamscan
Jan 20 01:54:19 cdc amavis[1588]: TROUBLE in pre_loop_hook: db_init: BDB bad db
env. at /var/spool/amavisd/db: Invalid argument, . at (eval 37) line 244.

[root at cdc amavisd]# ls -al /var/spool/amavisd/db/
total 8
drwx------  2 amavis amavis 4096 Jan 20 01:48 .
drwx------  5 amavis amavis 4096 Jan 20 01:49 ..

This is a FC4-updated machine.

[root at cdc amavisd]# rpm -V amavisd-new
[root at cdc amavisd]# rpm -q amavisd-new
amavisd-new-2.3.3-4


-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.




More information about the Fedora-perl-devel-list mailing list