cpan Module::Build install problem - Argument list too long

Philippe Lang philippe.lang at attiksystem.ch
Thu Jun 22 10:33:27 UTC 2006


Hi,

I'm facing a bug when trying to install a perl module from CPAN, which
requires the installation of Module::Build first.

This bug is apparently not new:
http://rt.cpan.org/Public/Bug/Display.html?id=19406. And until now, I
was not able to find a workaround. Setting the environment variables
LANG or LC_ALL to C (tips I could find on internet) did not correct
anything.


The problem is the following: if you type

> cpan Module::Build

... After a while, you get:

Running make test
/usr/bin/perl Build --makefile_env_macros 1 test
t/basic...........ok

t/compat..........ok 2/60Couldn't run Build.PL: Argument list too long
at /root/.cpan/build/Module-Build-0.2801/blib/lib/Module/Build/Compat.pm
line 200.
#     Failed test (t/compat.t at line 180)
t/compat..........NOK 3#     Failed test (t/compat.t at line 181)

t/compat..........NOK 4make[1]: *** No targets specified and no makefile
found.  Stop.
#     Failed test (t/compat.t at line 56)
t/compat..........NOK 5make[1]: *** No rule to make target `test'.
Stop.    
#     Failed test (t/compat.t at line 63)
t/compat..........NOK 6#     Failed test (t/compat.t at line 64)

t/compat..........NOK 7#                   'MAKE TEST

# MAKE[1]: ENTERING DIRECTORY
`/ROOT/.CPAN/BUILD/MODULE-BUILD-0.2801/T/_TMP/SIMPLE'
# MAKE[1]: LEAVING DIRECTORY
`/ROOT/.CPAN/BUILD/MODULE-BUILD-0.2801/T/_TMP/SIMPLE'
# '
#     doesn't match '(?-xism:DONE\.|SUCCESS)'
make[1]: *** No rule to make target `realclean'.  Stop.
#     Failed test (t/compat.t at line 66)
t/compat..........NOK 8make: *** [test] Interrupt    



... And at the end, the module cannot be installed:



Failed Test Stat Wstat Total Fail  List of Failed
------------------------------------------------------------------------
-------
t/compat.t    30  7680    60   30  3-10 13-20 38 41 43 45-46 48-55 59
3 tests and 31 subtests skipped.
Failed 1/21 test scripts. 30/670 subtests failed.
Files=21, Tests=670, 47 wallclock secs (30.05 cusr + 16.79 csys = 46.84
CPU) Failed 1/21 test programs. 30/670 subtests failed.
make: *** [test] Error 255
  /usr/bin/make test -- NOT OK
Running make install
  make test had returned bad status, won't install without force





This problem is specific to Redhat. I did the same job under FreeBSD 6.1
just before, without any problem.


Does anyone have an idea how I can install this Module? Is there maybe
an RPM package in order to install Module::Build?


Thanks!


----------------------------------
Philippe Lang, Ing. Dipl. EPFL
Attik System
rte de la Fonderie 2
1700 Fribourg
Switzerland
http://www.attiksystem.ch

Tel:  +41 (26) 422 13 75
Fax:  +41 (26) 422 13 76  




More information about the Fedora-perl-devel-list mailing list