[Bug 205455] New: RFE: Versioned Obsoletes for built-in perl modules

bugzilla at redhat.com bugzilla at redhat.com
Wed Sep 6 14:05:51 UTC 2006


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.




https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=205455

           Summary: RFE: Versioned Obsoletes for built-in perl modules
           Product: Fedora Core
           Version: fc5
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: normal
         Component: perl
        AssignedTo: rnorwood at redhat.com
        ReportedBy: nj at leverton.org
         QAContact: dkl at redhat.com
                CC: fedora-perl-devel-list at redhat.com


Description of problem:  
  
The perl rpm Obsoletes a number of modules which are now included in base perl  
5.8.8.  However some of these modules do get updated fairly regularly in 
between perl releases. 
 
As a system  
builder I prefer to update them by building an RPM with cpanflute for the 
specific module e.g. perl-Time-HiRes, so that I get simple and repeatable 
installations. But because of the Obsoletes in the perl RPM I have to remember 
which are in base perl and choose non-standard module names to get round it. 
  
If the Obsoletes tag could be made versioned, against the actual module  
version included in perl, it would simplify the task of keeping systems up to  
date between Fedora releases.  It would also make it it much easier when 
Fedora perl is updated because $PACKAGE_MANAGER could be trusted not to remove 
newer modules. 
  
At the time of writing the tags for perl 5.8.8 would be:  
  
Obsoletes: perl-Digest-MD5 <= 2.36  
Obsoletes: perl-MIME-Base64 <= 3.07  
Obsoletes: perl-libnet <= 1.19  
Obsoletes: perl-Storable <= 2.15  
Obsoletes: perl-CGI <= 3.15  
Obsoletes: perl-CPAN <= 1.7602  
Obsoletes: perl-DB_File <= 1.814  
Obsoletes: perl-Filter <= 1.32  
Obsoletes: perl-Filter-Simple <= 0.82  
Obsoletes: perl-Time-HiRes <= 1.86  
Obsoletes: perl-Test-Builder-Tester <= 1.02  
 
Version-Release number of selected component (if applicable):  
  
5.8.8-8

-- 
Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.




More information about the Fedora-perl-devel-list mailing list