[Bug 240540] yum breaks dependecies on upgrade (perl no-longer self-provides libperl.so)

bugzilla at redhat.com bugzilla at redhat.com
Sat Aug 11 23:45:56 UTC 2007

Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug report.

Summary: yum breaks dependecies on upgrade (perl no-longer self-provides libperl.so)


------- Additional Comments From gregory.douglas at sympatico.ca  2007-08-11 19:45 EST -------
(In reply to comment #22)
> I tried to reproduce this again.  This time I downgraded yum and
> yum-metadata-resolver to the versions distributed with FC6 and tried again, but
> yum has correctly found that perl-libs has to be installed.
> Greg, was your FC6 updated?  Or did you started from the original install of FC6?
> What were the versions of yum and yum-metatada-parser before the upgrade?

My FC6 was updated just before migrating to FC7 a couple of weeks ago.  Not
certain exact yum versions in FC6, but yum was at the most recent FC6 version as
of the end of July 2007.  I did a network update to FC7, since I do not have a
DVD drive.  

After the upgrade to FC7, I had to replace my old yum.conf and
fedora-updates.repo to newer files with the extension "rpmnew". This opened the
door to many new FC7 updates, but did not resolve the perl dependency problem.

I also tried to remove perl and ignore dependencies (rpm -e --allmatches
--nodeps perl) and then reinstall perl (yum install perl).  But again, the
dependencies were ignored.  Therefore I just manually installed them after
learning they were missing.

Hope this helps.

Configure bugmail: https://bugzilla.redhat.com/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

More information about the Fedora-perl-devel-list mailing list