[Bug 552105] New: cpanspec treats recommended dependencies to required

bugzilla at redhat.com bugzilla at redhat.com
Mon Jan 4 02:58:48 UTC 2010


Please do not reply directly to this email. All additional
comments should be made in the comments box of this bug.

Summary: cpanspec treats recommended dependencies to required

https://bugzilla.redhat.com/show_bug.cgi?id=552105

           Summary: cpanspec treats recommended dependencies to required
           Product: Fedora
           Version: 11
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: medium
          Priority: low
         Component: cpanspec
        AssignedTo: steve at silug.org
        ReportedBy: tim at tim-landscheidt.de
         QAContact: extras-qa at fedoraproject.org
                CC: steve at silug.org, fedora-perl-devel-list at redhat.com
    Classification: Fedora


Created an attachment (id=381464)
 --> (https://bugzilla.redhat.com/attachment.cgi?id=381464)
Patch to ignore "recommends" dependencies.

With cpanspec 1.78, META.yml's "recommends" dependencies are treated as
"requires" ones. That is way too harsh and easily requires many more package
updates than ordinarily necessary. The attached patch fixes this.

-- 
Configure bugmail: https://bugzilla.redhat.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.




More information about the Fedora-perl-devel-list mailing list