Using SELinux on samba mounted directories

Michael Kraus mkraus at
Wed Dec 22 00:58:04 UTC 2004


Previously under RH9, I had mounted a directory from a windows machine,
which was web-served by apache.

When I tried to do the same under FC3 I found that apache wasn't
recognising the directory, and learnt that this was because of SELinux.

I tried to "chcon -R -t httpd_sys_content_t <directory>" the directory
and found I couldn't. The directory was mounted using smb and an entry
in /etc/fstab.

Is there a way to edit the /etc/fstab file so that the context is set
when the directory is mounted?  (I hope this is all making sense, I'm
new to all of this.)



Michael S. E. Kraus
B. Info. Tech. (CQU), Dip. Business (Computing)
Software Developer
Wild Technology Pty Ltd
ABN 98 091 470 692
Level 4 Tiara, 306/9 Crystal Street, Waterloo NSW 2017, Australia
Telephone 1300-13-9453 |  Facsimile 1300-88-9453
The information contained in this email message and any attachments may
be confidential information and may also be the subject of client legal
- legal professional privilege. If you are not the intended recipient,
any use, interference with, disclosure or copying of this material is
unauthorised and prohibited.   This email and any attachments are also
subject to copyright.  No part of them may be reproduced, adapted or
transmitted without the written permission of the copyright owner.  If
you have received this email in error, please immediately advise the
sender by return email and delete the message from your system.

More information about the fedora-selinux-list mailing list