[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Inability to shutdown or reboot from gnome



Hi

I get that same thing.

Have you tried to do a 'setenforce 0' as root just before you do a Gnome
shutdown?

I tried that just now and it still halted at the console prompt (I boot
into run level 3 and then do a 'startx' as user to go to Gnome after boot
up)

A few weeks ago, I could shutdown from the Gnome menu, but perhaps that was
a bug in Gnome. A user should not be able to shutdown the system (!!).

When I am at the console prompt and try to do '/sbin/shutdown -r now', I
get the message now that only root can shutdown (this is proper).

Whether a user can shut down from the Gnome menu seems to be not a selinux
issue, but just a normal security 'tighterning up' - independent of selinux.

BobG



>Hi,
>
>The shutdown or reboot buttons from the gnome menu do not work as user
>when selinux is in enforcing mode. I get the error "unknown user" and it
>kicks me to the gdm login screen. I'm sure this is an easy one for you
>guys, and I have seen the question pop up on some other lists, but have
>not found a satisfactory answer. Hope you can help!!
>
>thanks, Matt

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]