[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Adobe Reader 7



On Mon 4/11/2005 6:25 PM, Daniel J Walsh wrote:
> Fred New wrote:
>
> > [fred darth ~]$ /usr/local/Adobe/Acrobat7.0/bin/acroread
> > /usr/local/Adobe/Acrobat7.0/Reader/intellinux/bin/acroread: error 
> > while loading shared libraries: 
> > /usr/local/Adobe/Acrobat7.0/Reader/intellinux/lib/libJP2K.so: cannot 
> > restore segment prot after reloc: Permission denied
> > [fred darth ~]$
> >
> Which policy are you running
> rpm -q -i selinux-policy-targeted

I am running the latest policy:

[fred darth ~]$ rpm  -q selinux-policy-targeted
selinux-policy-targeted-1.23.9-1
[fred darth ~]$

(I'm assuming you didn't really want the "-i" in "rpm -q -i ...".)

When I originally wrote a couple days ago, I was running the previous
policy, selinux-policy-targeted-1.23.8-2.  So I just now deleted the
/usr/local/Adobe directory and re-installed it - same results.
And "restorecon /usr/local/Adobe" doesn't change anything either.

I noticed when I installed selinux-policy-targeted-1.23.9-1
that the context for the Adobe Reader Firefox plugin, 
/usr/lib/firefox-1.0.2/plugins/nppdf.so, changed from
lib_t to shlib_t.  Everything in /usr/local/Adobe is still usr_t.

Fred

<<winmail.dat>>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]