differences between setfiles and restorecon? repeat of old thread?

Tom London selinux at gmail.com
Sat Aug 27 19:58:49 UTC 2005

Running targeted/enforcing, latest rawhide.

I created a 'backup' of my root lvm2 partition, mounted the new partition as 
/mnt, and copied the files via 'cp -dpR / /mnt'.

The copied files were all incorrectly labeled. (same result with cp 

I tried 'chroot /mnt; restorcon -v -R /', but it had no effect (returned 
immediately), as did any other resorecon attempted in the chroot'ed shell.

'setfiles -v /etc/selinux/targeted/contexts/files/file_contexts /' did the 
right thing. 

[Its almost as if restorecon is using the 'real' full pathname (with leading 
/mnt), and setfiles is using the 'chroot'ed' pathname (without the leading 

First, should the 'preserve' on cp have failed to copy the contexts? Second, 
why the difference in behavior between setfiles and restorecon in this 

Still curious,
Tom London
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/fedora-selinux-list/attachments/20050827/e855af07/attachment.htm>

More information about the fedora-selinux-list mailing list