Possible bug..

Net-Care Beheer beheer at net-care.nl
Sat Dec 10 19:17:05 UTC 2005

Well, after alot of trying i did a fixfiles relabel and right after that a touch /.autorelabel and rebooted the machine, and dovecot works again.
I still don't know what went wrong, but it works again.

Mark Evers

  ----- Original Message ----- 
  From: Net-Care Beheer 
  To: fedora-selinux-list at redhat.com 
  Sent: Saturday, December 10, 2005 1:43 AM
  Subject: Possible bug..

  First of all, i'm hoping i'm posting this the right way, but i've tried everything that i know

  I'm having problems with Dovecot, and i've asked for help in #fedore on freenode.net, without success and they adviced me to post it here.
  This is the error i get in /var/log/audit/audit.log when i start dovecot using webmin
  type=AVC msg=audit(1134174789.681:11): avc:  denied  { read } for  pid=2908 comm="dovecot" name="dovecot" dev=dm-0 ino=67858 scontext=system_u:system_r:dovecot_t tcontext=system_u:object_r:bin_t tclass=dir
  type=SYSCALL msg=audit(1134174789.681:11): arch=40000003 syscall=5 success=no exit=-13 a0=8059310 a1=8000 a2=0 a3=8000 items=1 pid=2908 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 comm="dovecot" exe="/usr/sbin/dovecot"
  type=CWD msg=audit(1134174789.681:11):  cwd="/usr/libexec/webmin/dovecot"
  type=PATH msg=audit(1134174789.681:11): item=0 name="." flags=101  inode=67858 dev=fd:00 mode=040755 ouid=0 ogid=0 rdev=00:00
  On my screen i get "Starting Dovecot Imap: Fatal: unlink_directory() failed for /var/run/dovecot-login: Permission denied"

  When i try to start dovecot using "service dovecot start" or /etc/rc.d/init.d/dovecot start i get "Starting Dovecot Imap:                                     [FAILED]"

  I've allready tried a fixfiles and even a touch /.autorelabel without luck.

  The system is fully updated with yum, and removing/adding dovecot doesn't make a difference.

  I Hope someone can help.


  Mark Evers
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/fedora-selinux-list/attachments/20051210/fe17e9a4/attachment.htm>

More information about the fedora-selinux-list mailing list