ProFTPD not showing all directorys.

Paul Howarth paul at
Sun Dec 18 11:08:27 UTC 2005

On Sun, 2005-12-18 at 01:32 +0100, Mark Evers wrote:
> Well, SELinux handed me another problem, i've been reading into the
> hoping i would get my
> answer,
> without luck.
> The problem is, when i connect to my FC4's Proftpd server i'm missing
> alot of directorys and files, and they do excist, i checked using SSH
> At first i could only see the "homes" directory, then i tried
> a fixfiles relabel, it brought back some dir's, but not the ones that
> are most important like public_html.
> Then i tried to disable SELinux to see if it's really SELinux related,
> and like magic, there are the missing dir's.
> What i want, but can't find is a way for users to have full access to
> there home dir, they are chrooted so they can't look "beyond" there
> own home dir, and still use SELinux.

Have a look at "man ftpd_selinux"; you'll probably find the following

# setsebool -P ftp_home_dir 

and if you're running proftpd as a daemon rather than from xinetd (which
is probably the case):

# setsebool -P ftpd_is_daemon 1


More information about the fedora-selinux-list mailing list