rawhide policy error messages

Stephen Smalley sds at tycho.nsa.gov
Tue Dec 20 20:17:34 UTC 2005

On Tue, 2005-12-20 at 14:14 -0500, Daniel J Walsh wrote:
> There was really no error here.  Basically I pulled hostname policy from 
> targeted.  So it reports this as an error.
> libsemanage then says Failed!  Even though it continues and completes 
> the reload.  Why does the libary say Failed?
> What is this error Data did not represent a module?
> This is actually a very scary looking warning.

Looking at libsemanage, it seems that this error message indicates that
the policy module package that you tried to install did not match the
requested operation to libsemanage, e.g. you tried to install a base
module as a non-base module or vice versa.  Example:

# /usr/sbin/semodule -i /etc/selinux/targeted/modules/active/base.pp
libsemanage.parse_module_headers: Data did not represent a module.

# /usr/sbin/semodule -b /etc/selinux/targeted/modules/active/base.pp

Such an error is indeed an error, and prevents installation of the
module from proceeding.  We should likely adjust the two error messages
there to clarify what it means (one should be "did not represent a base
module" and the other should be "did not represent a non-base module.")

Stephen Smalley
National Security Agency

More information about the fedora-selinux-list mailing list