policy updated, then selinux error?

Hongwei Li hongwei at wustl.edu
Fri Jul 8 19:49:24 UTC 2005


I just updated selinux target policy (including the source) from 1.17.30-2.96
to 1.17.30-3.16 on my fc3 linux system (kernel 2.6.11-1.35_FC3), and also
updated checkpolicy-1.17.5-1.2. The updating process did not show any error.

Then, I reboot the system that showed a lot of error message like:
invalid ... in /etc/selinux/targeted/src/policy/file_contexts/...  (it went
though so fast that I could not catch all the words).  The system is running,
then I go to /etc/selinux/targeted/src/policy and run make load and got:

# make load
mkdir -p /etc/selinux/targeted/policy
/usr/bin/checkpolicy -o /etc/selinux/targeted/policy/policy.18 policy.conf
/usr/bin/checkpolicy:  loading policy configuration from policy.conf
domains/unconfined.te:19:ERROR 'syntax error' at token '{' on line 3897:
typealias unconfined_t alias { kernel_t init_t initrc_t logrotate_t sendmail_t
sshd_t secadm_t sysadm_t rpm_t rpm_script_t xdm_t };
typeattribute tty_device_t { tty_device_t devpts_t };
/usr/bin/checkpolicy:  error(s) encountered while parsing configuration
make: *** [/etc/selinux/targeted/policy/policy.18] Error 1

I tried touch /.autorelable and reboot, the same error.

Can somebody tell what's wrong? how to fix it?


Hongwei Li

More information about the fedora-selinux-list mailing list