Java apps can't use network

dragoran dragoran at
Thu Jul 21 10:16:09 UTC 2005

Igor Wawrzyniak wrote:

>I tried running some Java apps on Fedora Core 4 with SELinux enabled and they 
>can't connect to network. The symptoms are strange (at least for me, I'm new 
>to SELinux):
>1) I use TARGETED policy - I thought it shouldn't restrict applications unless 
>they were explicitly listed?
>2) I tried setting SELINUX to PERMISSIVE - the apps still couldn't use 
>3) The apps are blocked silently - no info in syslog, regardless of SELINUX 
>All non-Java apps can use the network. All non-network related Java functions 
>seem to work just fine. I tried 2 versions of Sun JRE.
>Am I doing something wrong or is it a bug? Can I use my Java software without 
>totally disabling SELinux?
>Igor Wawrzyniak
>fedora-selinux-list mailing list
>fedora-selinux-list at
which java app?
when it still does not work in permissive mode than it isn't an selinux 
might be a firewall/nat problem which ports are this apps trying to use?

More information about the fedora-selinux-list mailing list