Java apps can't use network

Ivan Gyurdiev ivg2 at
Thu Jul 21 10:50:06 UTC 2005

On Thu, 2005-07-21 at 11:40 +0100, Igor Wawrzyniak wrote:
> On Thursday 21 July 2005 11:28, Ivan Gyurdiev wrote:
> > > 2) I tried setting SELINUX to PERMISSIVE - the apps still couldn't use
> > > network.
> >
> > So what evidence do you have that the problem is caused
> > by SELinux at all?
> Everything works when I disable SELinux.

Are the application you're testing open-sourced?
If so, which applications...

Have you tested with a free JRE, such as gij.

> > Have you tried if the problem occurs with selinux=disabled?
> Of course - I tried all 3 options. Doesn't work with permissive and enforcing, 
> works with disabled. 

Sounds like a possible kernel bug. Which kernel is this?
Did the problem begin to occur on a kernel upgrade or a policy
upgrade, or a library upgrade?

Are you absolutely sure you tested permissive mode (enforcing=0)?
What does /usr/sbin/getenforce say? Try /usr/sbin/setenforce 0.

More information about the fedora-selinux-list mailing list