Java apps can't use network

Igor Wawrzyniak Igor.Wawrzyniak at
Thu Jul 21 11:31:37 UTC 2005

On Thursday 21 July 2005 11:50, Ivan Gyurdiev wrote:
> Are the application you're testing open-sourced?
> If so, which applications...

Unfortunately, it's a commercial product.
I tried some other Java software and it seems to work. Strange...

> Have you tested with a free JRE, such as gij.

It doesn't run with gij.

> Sounds like a possible kernel bug. Which kernel is this?

I tried 2 standard Fedora kernels:

Other related software:

> Did the problem begin to occur on a kernel upgrade or a policy
> upgrade, or a library upgrade?

I only tried it a few days ago, there was no policy or library update since 
then. Should I try older versions of kernel/library/policy/all of them?

> Are you absolutely sure you tested permissive mode (enforcing=0)?
> What does /usr/sbin/getenforce say?

[root at dhcp-46 ~]# /usr/sbin/getenforce

> Try /usr/sbin/setenforce 0. 

Tried - nothing changed.

Igor Wawrzyniak

More information about the fedora-selinux-list mailing list