other problems after selinux-policy-targeted-1.17.30-3.2

Geoff Hogan geoff at ERINresearch.co.uk
Wed Jun 15 09:20:33 UTC 2005

I have had the same problem with openoffice 1.9.104.  I tried the 
setsebool command suggested below without success.  I have tried 
restorecon -v /opt/openoffice.org1.9.104/program/libicudata.so.26.0.1

ls -alZ /opt/openoffice.org1.9.104/program/libicudata.so.26.0.1 returns:
-r--r--r--  root     root     system_u:object_r:usr_t 

I am new to SELinux (it has just worked until now).  Do I need the 
policy source package installed to do these things (which I don't), or 
just the policy rpm?

Many thanks.


On Tue, 2005-06-14 at 14:23 +0200, Markus Ralser wrote:
 > Dear all,
 > an old error seems to reappear after uptdate to
 > selinux-policy-targeted-1.17.30-3.2.
 > When I try to start my openoffice now, i get
 > /etc/openoffice.org-1.9/program/soffice.bin: error
 > while loading shared libraries:
 > /opt/openoffice.org1.9.104/program/libicudata.so.26:
 > cannot restore segment prot after reloc: Permission
 > denied


setsebool -P allow_execmod=true allow_execmem=true

This is a workaround for an upgrade bug.

More information about the fedora-selinux-list mailing list