permission denied on shared library

Daniel J Walsh dwalsh at
Wed Jun 29 18:43:44 UTC 2005

rich turner wrote:

>i have installed a 3rd party application that worked with fc3 but no longer 
>works with fc4. i am getting the following error:
>stio: error while loading shared libraries: /usr/lib/ cannot 
>restore segment prot after reloc: Permission denied.
>when i run the command "setenforce 0" it works so my thoughts are that it is 
>not setup properly with selinux.
># ls -l /usr/lib/
>lrwxrwxrwx  1 root root 28 Jun 26 05:14 /usr/lib/ 
>-> /opt/storix/lib/
># ls -lZ /usr/lib/
>lrwxrwxrwx  root     root     
>system_u:object_r:lib_t          /usr/lib/
># ls -lZ /opt/storix/lib/
>-rw-r--r--  root     root     
>system_u:object_r:shlib_t        /opt/storix/lib/
>i have seen this error in a number of searches, and the most common solution 
>is to turn selinux off. there must be a better way to get this to work.
>fedora-selinux-list mailing list
>fedora-selinux-list at
Tonights Fedora Policy selinux-policy-targeted-1.17.30-3.15 should fix this.
The .16 test release is available on


More information about the fedora-selinux-list mailing list